PROBLEM WITH EB006 V7 AND PPP

For Flowcode users to discuss projects, flowcharts, and any other issues related to Flowcode 4.
To post in this forum you must have a registered copy of Flowcode 4 or higher. To sign up for this forum topic please use the "Online Resources" link in the Flowcode Help Menu.

Moderator: Benj

mamadou
Posts: 14
Joined: Tue May 12, 2015 10:00 am
Has thanked: 4 times
Contact:

PROBLEM WITH EB006 V7 AND PPP

Postby mamadou » Mon May 25, 2015 3:03 pm

i'm a member of ARABCOM (a tunisian company and the only distributor of matrix equipements) i tried to test the RFID packs wich came with EB006-00-7 multiprogramer devices and EB052 RFID READER and flowcode V4 and other devices (EB005,EB004...)
my problem is with sending the (.HEX) files from flowcode V4 directly to the chip it said "USB cable not connected" how can i fix that ?
same problem with PPP which said things like: "USB cable not connected continue ?" and "could not ID the on board chip" and "PIC not erased retry another 10 times" and "erase failed" and finally "programming failed config1".i've already removed the 16F88 and i put (LVP = off) in the configuration menu
i'm using :
- windows 7 32bits
-FLOWCODE V4.5
- eb006 v7
- PIC 16F877A
- an external power adapter and jumper on PSU not USB
PLEAZE HELP ME I'M DESPERATE :roll: :roll: :roll: :roll: :roll:

User avatar
DavidA
Matrix Staff
Posts: 1021
Joined: Fri Apr 23, 2010 2:18 pm
Location: Matrix Multimedia Ltd
Has thanked: 49 times
Been thanked: 264 times
Contact:

Re: PROBLEM WITH EB006 V7 AND PPP

Postby DavidA » Tue May 26, 2015 8:52 am

Hello,

Please note that v4 of Flowcode is out of support.

Please check you have installed the correct USB driver. The driver for version 7 of the EB006 is listed below:

http://www.matrixtsl.com/resources/getresource.php?id=6

If you have installed the driver correctly then you should see the Eb006 Multiprogrammer in Windows Device Manager. (Control panel >> Device Manager).

mamadou
Posts: 14
Joined: Tue May 12, 2015 10:00 am
Has thanked: 4 times
Contact:

Re: PROBLEM WITH EB006 V7 AND PPP

Postby mamadou » Tue May 26, 2015 11:53 am

THE DRIVER WORKS CORRECTLY BUT THE PROBLEM IS THE SAME
PLEAZZZZZZZZZZE HELP ME I'M ALMOST OUT OF TIME :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry:

User avatar
DavidA
Matrix Staff
Posts: 1021
Joined: Fri Apr 23, 2010 2:18 pm
Location: Matrix Multimedia Ltd
Has thanked: 49 times
Been thanked: 264 times
Contact:

Re: PROBLEM WITH EB006 V7 AND PPP

Postby DavidA » Tue May 26, 2015 12:32 pm

Hello,

"USB cable not connected" seems to suggest that the EB006 is not plugged in/detected correctly. Can you provide a screenshot of your device in "Device Manager"?

For help taking a screenshot see this site: http://www.take-a-screenshot.org/

mamadou
Posts: 14
Joined: Tue May 12, 2015 10:00 am
Has thanked: 4 times
Contact:

Re: PROBLEM WITH EB006 V7 AND PPP

Postby mamadou » Wed May 27, 2015 12:29 pm

screenshots.rar
(111.67 KiB) Downloaded 317 times
screenshots.rar
(111.67 KiB) Downloaded 317 times
DavidA wrote:Hello,

"USB cable not connected" seems to suggest that the EB006 is not plugged in/detected correctly. Can you provide a screenshot of your device in "Device Manager"?

For help taking a screenshot see this site: http://www.take-a-screenshot.org/


sorry it took me a while to answer you here is the screenshots you demand it

User avatar
Benj
Matrix Staff
Posts: 12616
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 3521 times
Been thanked: 3410 times
Contact:

Re: PROBLEM WITH EB006 V7 AND PPP

Postby Benj » Wed May 27, 2015 12:53 pm

Hello,

Could it be a faulty chip? Do you have a second chip you could try to double check.

mamadou
Posts: 14
Joined: Tue May 12, 2015 10:00 am
Has thanked: 4 times
Contact:

Re: PROBLEM WITH EB006 V7 AND PPP

Postby mamadou » Wed May 27, 2015 1:29 pm

Benj wrote:Hello,

Could it be a faulty chip? Do you have a second chip you could try to double check.

already tried 2 RFID PACKS but no use so I DON'T THINK IT'S A CHIP PROBLEM OR A multiprogrammer problem i think it's a configuration problem so here is the the bord configuration :
jumper j12 ,j13 ,j14 on USB position
jumper 29 on USB position not PSU
jumper j18,j19 on "OSC" position
clock selection = XTAL
clock speed = FAST
THE LVP SELECTION JUMPER = j11,j16,j17 => all on the left position (I/O PORT RB3,RB4,RB5)
check the RAR file to see the pack
PLEAZE HELP ME :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry:
Attachments
RFID block.rar
(1 MiB) Downloaded 308 times

User avatar
Benj
Matrix Staff
Posts: 12616
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 3521 times
Been thanked: 3410 times
Contact:

Re: PROBLEM WITH EB006 V7 AND PPP

Postby Benj » Wed May 27, 2015 2:22 pm

Hello,

I think the v7 board requires 12V to re-program the chips. Do you have a 12V DC power supply you can connect?

You will also have to move jumper 29 to the PSU position.

From memory the v8 board brought in the charge pump allowing USB voltage to be scaled up to 12V needed by the PIC. The USB setting is so you can power your application from USB if you wish or reprogram using LVP if you dare :wink: .

Fingers crossed this should fix the problem your having.

Edit: Confirmed the v7 board does not have the charge pump circuit so you need a 12V PSU to reprogram.
These users thanked the author Benj for the post:
mamadou (Fri May 29, 2015 12:33 pm)
Rating: 5.88%
 

mamadou
Posts: 14
Joined: Tue May 12, 2015 10:00 am
Has thanked: 4 times
Contact:

Re: PROBLEM WITH EB006 V7 AND PPP

Postby mamadou » Wed May 27, 2015 5:18 pm

Benj wrote:Hello,

I think the v7 board requires 12V to re-program the chips. Do you have a 12V DC power supply you can connect?

You will also have to move jumper 29 to the PSU position.

From memory the v8 board brought in the charge pump allowing USB voltage to be scaled up to 12V needed by the PIC. The USB setting is so you can power your application from USB if you wish or reprogram using LVP if you dare :wink: .

Fingers crossed this should fix the problem your having.

Edit: Confirmed the v7 board does not have the charge pump circuit so you need a 12V PSU to reprogram.

i aready have an external power adapter it came with the RFID pack
maximum power on the DC Supply is 13.5V NOT 12V
WILL IT MAKE A DIFFERENCE ?

User avatar
Benj
Matrix Staff
Posts: 12616
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 3521 times
Been thanked: 3410 times
Contact:

Re: PROBLEM WITH EB006 V7 AND PPP

Postby Benj » Thu May 28, 2015 10:43 am

Hello,

The 13.5V setting will be fine with the v7 EB006 board.

Let us know how you get on.

mamadou
Posts: 14
Joined: Tue May 12, 2015 10:00 am
Has thanked: 4 times
Contact:

Re: PROBLEM WITH EB006 V7 AND PPP

Postby mamadou » Thu May 28, 2015 11:36 am

Benj wrote:Hello,

The 13.5V setting will be fine with the v7 EB006 board.

Let us know how you get on.

IT DIDN'T WORK i don't know why ? i even used the LVP function
GUYS I'M OUTTA OPTIONS PLEAZE HELP ME :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry:

User avatar
Benj
Matrix Staff
Posts: 12616
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 3521 times
Been thanked: 3410 times
Contact:

Re: PROBLEM WITH EB006 V7 AND PPP

Postby Benj » Thu May 28, 2015 12:05 pm

Hello,

i even used the LVP function


What do you mean by this? Do you mean you enabled LVP in the config settings? I would strongly advise you disable LVP in the config as it can cause all kinds of issues and you loose a I/O pin right in the middle of PortB.

What error messages are you getting when you try and program the device using the power supply?

mamadou
Posts: 14
Joined: Tue May 12, 2015 10:00 am
Has thanked: 4 times
Contact:

Re: PROBLEM WITH EB006 V7 AND PPP

Postby mamadou » Thu May 28, 2015 9:15 pm

:D :D :D :D :D :D :D :D :D :D :D IT WORKED :D :D :D :D :D :D :D :D :D :D :D :D :D

THANK YOU GUYS YOU ARE LIFE SAVERS

but i still have this weird message " is HEX file intented for 18F device ?"
plus when i try to make the RFID module read the MIFARE tag i should make the tag very close to the antenna (it almost touches it) while IT SHOULD BE READ FROM A "3Cm" DISTANCE AT LEAST WHILE I'M USING 13.56MhZ FREQUENCY

the UIDs are as follows:

MIFARE CARD 1 UID: 61 175 227 175
MIFARE CARD 2 UID: 45 152 229 175

i want to assign each UID to a person ( UID1 => person A)(UID2 => person B)
if any of these tags are detected a relay board (EB038)(PORT B) will send 14V to command an electronique lock and a message will be displayed in an LCD board (EB005)(PORT A) to greet this person
ELSE if there is a MIFARE tag with an another UID not like the other previous UIDs the board will stay SHUTT and a message on the LCD will say "unknown tag access restricted"
ELSE a message will say "no TAG detected"

also how can i command a relay board " EB038" attached to PORT B ?

YOU'LL BE EXTREMELY HELPFUL IF YOU CAN SEND ME A WHOLE FLOWCHART OR AT LEAST ANSWER THESE QUESTIONS
{ PIC 16F877A
EB052 RFID BOARD => PORT C
EB038 RELAY BOARD => PORT B
EB005 LCD => PORT A}
PLEAZE HELP ME :roll: :roll: :roll:

mamadou
Posts: 14
Joined: Tue May 12, 2015 10:00 am
Has thanked: 4 times
Contact:

Re: PROBLEM WITH EB006 V7 AND PPP

Postby mamadou » Sat May 30, 2015 10:24 pm

mamadou wrote::D :D :D :D :D :D :D :D :D :D :D IT WORKED :D :D :D :D :D :D :D :D :D :D :D :D :D

THANK YOU GUYS YOU ARE LIFE SAVERS

but i still have this weird message " is HEX file intented for 18F device ?"
plus when i try to make the RFID module read the MIFARE tag i should make the tag very close to the antenna (it almost touches it) while IT SHOULD BE READ FROM A "3Cm" DISTANCE AT LEAST WHILE I'M USING 13.56MhZ FREQUENCY

the UIDs are as follows:

MIFARE CARD 1 UID: 61 175 227 175
MIFARE CARD 2 UID: 45 152 229 175

i want to assign each UID to a person ( UID1 => person A)(UID2 => person B)
if any of these tags are detected a relay board (EB038)(PORT B) will send 14V to command an electronique lock and a message will be displayed in an LCD board (EB005)(PORT A) to greet this person
ELSE if there is a MIFARE tag with an another UID not like the other previous UIDs the board will stay SHUTT and a message on the LCD will say "unknown tag access restricted"
ELSE a message will say "no TAG detected"

also how can i command a relay board " EB038" attached to PORT B ?

YOU'LL BE EXTREMELY HELPFUL IF YOU CAN SEND ME A WHOLE FLOWCHART OR AT LEAST ANSWER THESE QUESTIONS
{ PIC 16F877A
EB052 RFID BOARD => PORT C
EB038 RELAY BOARD => PORT B
EB005 LCD => PORT A}
PLEAZE HELP ME :roll: :roll: :roll:

OK GUYS NOW I'AM IN REAL TROUBLE :cry: :cry: :cry: :cry: :cry: :
y'all didn't answer my question : how to command the relay board ? what's the command i should use in FLOWCODE to do that ?
plus i just figured out that the company doesn't have a relay board EB038 so i had to make one with 1 relay instead of 4 relays like the EB038 using PROTEUS ISIS
infortunately i dind't find the exact components so i'll send a few pictures in ".RAR" file so PLEASE CHECK THEM OUT PLEEEEEEEEAZE
i used :
-a relay 12V : G5CLE-1-DC12
-A TRANSISTOR : BC337
-A D9 CONNECTOR
i tried to pick these components by choosing the ones close to the EB038 parameters
this RELAY BLOCK will be attached to the LED block as you will see in the picture in the ".RAR" file (block number 6) wich will be attached to an ELECTRIQUE LOCK
PLEASE GUYS TELL ME IF THIS BLOCK I MADE WILL WORK OR IS IT DANGEROUS TO PUT WITH THE OTHER BLOCKS ?
PLEAZE HELLLLLLLLLLLLLLLP MEEEEEEEE :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry:
Attachments
relay board.rar
(502.69 KiB) Downloaded 293 times

siwo278
Posts: 39
Joined: Tue Feb 12, 2013 9:07 am
Has thanked: 4 times
Been thanked: 5 times
Contact:

Re: PROBLEM WITH EB006 V7 AND PPP

Postby siwo278 » Sun May 31, 2015 6:23 am

Welcome

In my opinion you so connectivities . Activation of the relay will only accompany the lighting of the LED Nothing should happen. The control transistor may be any from the group npn .

Witam
Moim zdaniem możesz tak połączyć. Aktywacji przekaźnika towarzyszyć będzie tylko oświetlenie LED, nic nie powinno się zdarzyć.Sterujący tranzystor może być dowolny z grupy npn.

User avatar
medelec35
Valued Contributor
Valued Contributor
Posts: 7291
Joined: Sat May 05, 2007 2:27 pm
Location: Northamptonshire, UK
Has thanked: 1981 times
Been thanked: 2874 times
Contact:

Re: PROBLEM WITH EB006 V7 AND PPP

Postby medelec35 » Sun May 31, 2015 12:11 pm

Hi mamadou,
II just had a look at your circuit diagram and BC337 is suitable for driving Relay.
Resistor is a bit high in value. you would be better using between 2K2 and 4K7

mamadou wrote:PLEASE GUYS TELL ME IF THIS BLOCK I MADE WILL WORK OR IS IT DANGEROUS TO PUT WITH THE OTHER BLOCKS ?
PLEAZE HELLLLLLLLLLLLLLLP MEEEEEEEE

Please don't use caps like this as on forums it's classed as shouting and is frowned upon.

The transistor/base resistor will provide isolation between microcontroller and 12V going into relay/transistor collector.
So your relay board will be safe to use and will not be dangerous to any other blocks.
Just make sure you use a fast recovery diode.


Martin
These users thanked the author medelec35 for the post:
mamadou (Sun May 31, 2015 11:05 pm)
Rating: 5.88%
 
If your hardware is not working as expected, try looking here first:
http://www.matrixmultimedia.com/mmforum ... =26&t=6936

mamadou
Posts: 14
Joined: Tue May 12, 2015 10:00 am
Has thanked: 4 times
Contact:

Re: PROBLEM WITH EB006 V7 AND PPP

Postby mamadou » Mon Jun 01, 2015 12:05 am

medelec35 wrote:II just had a look at your circuit diagram and BC337 is suitable for driving Relay.
Resistor is a bit high in value. you would be better using between 2K2 and 4K7

Martin


why do i have to use 2k2 resistor instead of 22k ? is it dangerous not to replace it or it won't make any difference and the board will be fine :?: :?: :?: :?: :?:
PLEAZE NOTICE THAT THIS RELAY BOARD THAT I MADE IS LINKED TO 1 LED OF THE LED BOARD AN IT MUSTN'T WORK ONLY IF ONE OF THE LEDs IS LIGHTNING (THE ONE ATTACHED TO PIN 6 of the D9 CONNECTOR OF THE LED BOARD)(CHEK THE HIGHLIGHTENED PART IN THE PICTURE I SENDED)
plus i have a problem using the LCD device : i want to write a message in 2 lines : line 1 = hello
line 2 = mahmoud
pleaze help me with this task :cry: :cry: :cry:
Attachments
Capture.PNG
RELAY BOARD SCHEME AND HIGHLIGHTENED PART WILL COMMAND THE RELAY BOARD THROUGH TH D9 CONNECTOR
Capture.PNG (47.78 KiB) Viewed 13886 times

siwo278
Posts: 39
Joined: Tue Feb 12, 2013 9:07 am
Has thanked: 4 times
Been thanked: 5 times
Contact:

Re: PROBLEM WITH EB006 V7 AND PPP

Postby siwo278 » Mon Jun 01, 2015 7:26 am

Welcome

In my opinion if you don't want to exchange the resistor of the base of the BC337 transistor don't change. It should work from 22k. This resistor is responsible for the proper guidance of this transistor and it is possible to enumerate his accurate value. For LED diode nothing will happen, or even uP877.

As for LCD and his guidance look into examples flowcode, there everything great is shown.

Witam

Moim zdaniem jeśli nie chcesz wymieniać rezystora bazy tranzystora BC337 to nie zmieniaj. Powinno zadziałać z 22k. Rezystor ten jest odpowiedzialny za odpowiednie sterowanie tego tranzystora a jego dokładną wartość można wyliczyć. Diodzie LED nic się nie stanie, czy nawet uP877.

Jeśli chodzi o LCD i jego sterowanie to zajrzyj do przykładów flowcode, tam wszystko jest fajnie pokazane.
Attachments
LCD Tutorial.fcf
(7.5 KiB) Downloaded 311 times
These users thanked the author siwo278 for the post:
mamadou (Mon Jun 01, 2015 9:53 am)
Rating: 5.88%
 

User avatar
medelec35
Valued Contributor
Valued Contributor
Posts: 7291
Joined: Sat May 05, 2007 2:27 pm
Location: Northamptonshire, UK
Has thanked: 1981 times
Been thanked: 2874 times
Contact:

Re: PROBLEM WITH EB006 V7 AND PPP

Postby medelec35 » Mon Jun 01, 2015 9:30 am

mamadou wrote:why do i have to use 2k2 resistor instead of 22k ? is it dangerous not to replace it or it won't make any difference and the board will be fine


siwo278 wrote:In my opinion if you don't want to exchange the resistor of the base of the BC337 transistor don't change. It should work from 22k.


Of course that is up to you and I’m not saying won’t work.
My factors for calculating 2k2 are.
1) Use the lowest gain for BC337 which i have rounded down to 100
2) VOH out from microcontroller is VDD – 0.7
3) VBE for saturation = 0.7
Therefore min IB= IC/HFE
= (12/360)/100
= 330E-6
Min base bias resistance = (VOH microcontroller- VBEsat)/IB
= (4.3 - 0.7)/ 330E-6
= 10K9 ohms.
So any value higher than 10K9 there is no guarantee relay will operate.
Even if relay does operate then if transistor is not fully saturated then more power will be consumed by the transistor, heating it up unnecessary.

Personally I would use a lower value to absolutely guarantee saturation.
If you were worried that 2K2 will damage transistor then looking at Philips datasheet for BC337 you will see that maximum base current is 200mA.

One other thing it looks like the relay board EB038 uses 2K2 resistors, but it’s not very clear:
EB038.png
EB038.png (69.63 KiB) Viewed 13872 times


So if it's used in that board how can it be dangerous and damage other boards?
These users thanked the author medelec35 for the post:
Benj (Mon Jun 01, 2015 10:29 am)
Rating: 5.88%
 
If your hardware is not working as expected, try looking here first:
http://www.matrixmultimedia.com/mmforum ... =26&t=6936

mamadou
Posts: 14
Joined: Tue May 12, 2015 10:00 am
Has thanked: 4 times
Contact:

Re: PROBLEM WITH EB006 V7 AND PPP

Postby mamadou » Tue Jun 02, 2015 2:19 pm

medelec35 wrote:
mamadou wrote:why do i have to use 2k2 resistor instead of 22k ? is it dangerous not to replace it or it won't make any difference and the board will be fine


siwo278 wrote:In my opinion if you don't want to exchange the resistor of the base of the BC337 transistor don't change. It should work from 22k.


Of course that is up to you and I’m not saying won’t work.
My factors for calculating 2k2 are.
1) Use the lowest gain for BC337 which i have rounded down to 100
2) VOH out from microcontroller is VDD – 0.7
3) VBE for saturation = 0.7
Therefore min IB= IC/HFE
= (12/360)/100
= 330E-6
Min base bias resistance = (VOH microcontroller- VBEsat)/IB
= (4.3 - 0.7)/ 330E-6
= 10K9 ohms.
So any value higher than 10K9 there is no guarantee relay will operate.
Even if relay does operate then if transistor is not fully saturated then more power will be consumed by the transistor, heating it up unnecessary.

Personally I would use a lower value to absolutely guarantee saturation.
If you were worried that 2K2 will damage transistor then looking at Philips datasheet for BC337 you will see that maximum base current is 200mA.

One other thing it looks like the relay board EB038 uses 2K2 resistors, but it’s not very clear:
EB038.png


So if it's used in that board how can it be dangerous and damage other boards?

OK guys will change the resistance from 22k to 2k2 on the relay board and i will put on PORT E what do you think ?
plus i still have a problem with the MIFARE card :
the RFID MDULE can not detect the MIFARE CARD from 3Cm but only if i attach the card to the antenna
IS IT A FREQUENCY PROBLEM ? AND IF IT IS AFREQUENCY PROBLEM ? should i adjust it with the TUNING CAPACITATOR ?

User avatar
Benj
Matrix Staff
Posts: 12616
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 3521 times
Been thanked: 3410 times
Contact:

Re: PROBLEM WITH EB006 V7 AND PPP

Postby Benj » Tue Jun 02, 2015 2:27 pm

Hello,

If you slowly adjust the tuning capacitor with the card held over the antenna then this should help to tune into the frequency of the MIFARE card and give you better range.

Another helpful thing you can do is to fit a ferrite block underneath the board's antenna if there is not already one there. This helps to focus the RF energy towards the card. We supply the ferrite block as part of our solutions to avoid problems with the metal backplane the boards are bolted to.

mamadou
Posts: 14
Joined: Tue May 12, 2015 10:00 am
Has thanked: 4 times
Contact:

Re: PROBLEM WITH EB006 V7 AND PPP

Postby mamadou » Tue Jun 02, 2015 2:34 pm

Benj wrote:Hello,

If you slowly adjust the tuning capacitor with the card held over the antenna then this should help to tune into the frequency of the MIFARE card and give you better range.

Another helpful thing you can do is to fit a ferrite block underneath the board's antenna if there is not already one there. This helps to focus the RF energy towards the card. We supply the ferrite block as part of our solutions to avoid problems with the metal backplane the boards are bolted to.


FERRIT block ? you mean those roundy plastic stickers i already fitted them with the board
pleaze send me a picture of them if i don't know what i'm talking about :roll: :roll: :roll: :roll: :roll:
and THANKS :) :) :)

User avatar
Benj
Matrix Staff
Posts: 12616
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 3521 times
Been thanked: 3410 times
Contact:

Re: PROBLEM WITH EB006 V7 AND PPP

Postby Benj » Tue Jun 02, 2015 4:21 pm

Hello,

The round stickers are the boards rubber feet.

This is the part we add to the underside of the EB052 board when used in a solution.

http://uk.farnell.com/ferroxcube/plt38- ... ku=3056156
These users thanked the author Benj for the post:
mamadou (Tue Jun 02, 2015 7:34 pm)
Rating: 5.88%